2007年5月21日

長らく(といっても Linux 上で Emacs 使うようになったのはたかだか9ヶ月ほど前)Emacs21 を使ってきましたが、ここいらで Emacs22 に移行してみたいと思います。なんとなく。

試したバージョンは Debian/sid にパッケージ登録されてる emacs-snapshot-nox で、バージョンは 22.0.95.1。さて、今の .emacs で動くかな。。。

とりあえず、Meadow用の設定の残りかすと思われる↓の箇所でエラーが出ただけですんなり起動。

(tool-bar-mode 0)

この変数は 22 にはないっぽい(?)ので、Emacs21 のときのみ読み込む用に変更。変更必須はここだけ。

変数名に「*」は使っちゃダメ

22 からは .emacs を開くと、lisp の中で変数名に「*」を使うのは安全じゃないよ!とかっていう警告がでてたので該当箇所を修正。

Before

;;;;;; test OS/Versions 
(defvar *on_windows* (featurep 'meadow)) 
(defvar *on_linux* (string-match "linux" system-configuration)) 
(defvar *v22* (string-match "GNU Emacs 22." (version))) 
(defvar *v21* (string-match "GNU Emacs 21." (version))) 

After

;;;;;; test OS / Emacs version 
(setq is_meadow (featurep 'meadow)) 
(setq is_linux (string-match "linux" system-configuration)) 
(setq v22 (eq emacs-major-version '22)) 
(setq v21 (eq emacs-major-version '21)) 

この4つだけ。。

まだ1日しか使ってないけど、いい感じなのでもう emacs21 は aptitude purge しました。。

もう時代は Emacs22 ですよ。たぶん。

これを機に、さっぱり使ったことない VC モードを、会社で uno さんがよさげに使っていたので自分も使ってみたい思います。

よーし。

Comments

トラックバック

トラックバックURL: